Student Applications: TritonLink WebReg and EASy
Incident Report for ITS Network & Systems
Resolved
The issue affecting the various student applications has been resolved. Users still experiencing difficulties are asked to restart their web browser. For further assistance please contact the Service Desk at (858)246-HELP(4357) or via email at servicedesk@ucsd.edu. We thank you for your patience.
Posted Aug 10, 2020 - 21:48 PDT
Investigating
We are currently investigating an issue affecting student applications including TritonLink WebReg and EASy. Access to these sites may be slow or unavailable during this time; please monitor this page for updates on the situation. We apologize for the inconvenience.
Posted Aug 10, 2020 - 21:05 PDT
This incident affected: Academic Services.