Verizon outage
Incident Report for ITS Network & Systems
Resolved
This incident has been resolved.
Posted Jan 27, 2023 - 12:45 PST
Investigating
Verizon is investigating possible issues with cellular services on campus. These services may be slow or unavailable at this time. Visit the following Verizon page for more information https://www.verizon.com/support/residential/service-outage.
Posted Jan 25, 2023 - 13:28 PST