Link Family Applications
Incident Report for ITS Network & Systems
Resolved
The issues with the Link Family Applications have been resolved. If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.

Thanks again for your patience during the service outage.
Posted Nov 06, 2018 - 09:12 PST
Investigating
The Link Family Applications are currently slow or unavailable.
If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu.

Thanks again for your patience during the service outage.
Posted Nov 06, 2018 - 07:18 PST
This incident affected: Academic Services and Business Services.