ITS Service Desk phone issues
Incident Report for ITS Network & Systems
Resolved
The ITS Service Desk Phones are now operational.
Posted Aug 17, 2019 - 12:45 PDT
Investigating
The ITS Service Desk is currently experiencing issues with their phone system. If you need to reach the Service Desk, please email servicedesk@ucsd.edu, leaving your phone number, and one of the technicians will call you back as soon as possible.
Posted Aug 17, 2019 - 12:38 PDT
This incident affected: Phones and Voicemail.