Email System
Incident Report for ITS Network & Systems
Resolved
The issue affecting the email system has been resolved. For further assistance please contact the Service Desk at (858)246-HELP(4357) or via email at servicedesk@ucsd.edu. We thank you for your patience.
Posted Mar 13, 2018 - 08:40 PDT
Investigating
The campus email system is currently experiencing an outage. Users may have difficulties connecting to the mail servers or sending and receiving messages. Our team is working on this issue and we hope to have it resolved soon; please monitor this page for updates on the situation. Thank you for your patience.
Posted Mar 13, 2018 - 08:00 PDT