Email Delays or not going through
Incident Report for ITS Network & Systems
Resolved
The issue affecting email has been resolved. For further assistance please contact the Service Desk at (858)246-HELP(4357) or via email at servicedesk@ucsd.edu. We thank you for your patience.
Posted Aug 09, 2019 - 09:57 PDT
Identified
We are currently experiencing delays for emails coming into and off-campus. Our team is working on the issue and will have it resolved shortly; please monitor this page for updates. We apologize for the inconvenience.
Posted Aug 09, 2019 - 07:47 PDT
This incident affected: Email.