Student Applications: TritonEd / Blackboard Status
Incident Report for ITS Network & Systems
Resolved
The issue affecting student application TritonEd /Blackboard has been resolved. Users still experiencing difficulties are asked to restart their web browser. For further assistance please contact the Service Desk at (858)246-HELP(4357) or via email at servicedesk@ucsd.edu. We thank you for your patience.
Posted Apr 12, 2019 - 10:00 PDT
Identified
Our team has identified intermittent slowness with Blackboard and are working to resolve it as quickly as possible. We will update this page as information becomes available. We apologize for the inconvenience.
Posted Apr 11, 2019 - 12:14 PDT
This incident affected: Academic Services.