UC Learning Center - TLS update
Incident Report for ITS Network & Systems
Resolved
This incident has been resolved.
Posted May 25, 2018 - 07:58 PDT
Identified
UC Learning Center - Important TLS 1.0/1.1 Disablement Notice

SumTotal Systems is requiring an upgrade to TLS 1.2 or higher for your site, to align with industry best practices for security and data integrity. This notification contains information pertaining to SumTotal Systems' disablement of the TLS 1.0 and 1.1 encryption protocols.

What is the change?
TLS 1.0 and 1.1 encryption protocols will be disabled on our data center, which will prevent customers still using these TLS versions from accessing their SumTotal applications. Most modern up to date web browsers already support TLS 1.2. If you are using such a web browser you are likely already using TLS 1.2.

How will customers be impacted?
After SumTotal Systems disables TLS 1.0 and 1.1, any inbound connections that rely on TLS 1.0 or 1.1 will fail. This includes end-user web browsers as well as any programmatic API calls.
Note: If you are not using the current version of your Web browser, please take a few moments to upgrade it now. Browsers released prior to 2014 may not support TLS 1.2. You can check your browser's TLS support by visiting https://www.howsmyssl.com/ or review the attachments.

How can customers avoid a service disruption?
The action required by your organization will depend on
1. which web browser versions your end-users are using to connect to SumTotal's applications and
2. if your organization is currently utilizing SumTotal's Web Services API
Please review our web browser compatibility list (attached) and ensure your end users are not using unsupported web browsers. Also, please consult those in your organization who control/manage API calls to your SumTotal application to ensure these calls are being done via compatible client agents.

When is this happening?
This change has been tested and implemented in our development labs as well as our PCI High Security environment. SaaS and hosted environments will be implemented per the following schedule:

All Stage: April 13, 2018
All Production: May 12, 2018

Please contact ASK for further information or questions at lms-support@ucsd.edu or https://ask.ucsd.edu
Posted May 03, 2018 - 11:45 PDT