Concur Expense Module
Incident Report for ITS Network & Systems
Resolved
ITS has confirmed that the issues affecting Concur Expense Module have been resolved. Thank you for your patience as Concur worked to restore service.

If you experience any additional issues or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or at (858) 246-4357.
Posted Jun 21, 2022 - 12:32 PDT
Investigating
The Expense module is currently unavailable. SAP Concur is aware of the issue and is working to resolve. Please check open.concur.com for status updates.
Posted Jun 21, 2022 - 12:13 PDT
This incident affected: Business Services.