Campus Telephone System
Incident Report for ITS Network & Systems
Resolved
All problems with the listed service Campus Telephone System have been resolved.

If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.

Thanks again for your patience during the service outage.
Posted Feb 24, 2020 - 15:36 PST
Investigating
We are currently investigating an issue affecting the campus telephone system at multiple locations across campus. Please monitor this page for updates on the situation. We apologize for the inconvenience.
Posted Feb 24, 2020 - 15:24 PST
This incident affected: Phones and Voicemail.