Campus Telephone System
Incident Report for ITS Network & Systems
Resolved
All voice lines are restored
Posted Aug 12, 2019 - 19:22 PDT
Update
Our team has identified the issue affecting the telephone system and is working to resolve it as quickly as possible. We will update this page as information becomes available. We apologize for the inconvenience.
Posted Aug 12, 2019 - 17:03 PDT
Identified
Our team has identified the issue affecting the telephone system and is working to resolve it as quickly as possible. We will update this page as information becomes available. We apologize for the inconvenience.
Posted Aug 12, 2019 - 14:20 PDT
Investigating
We are currently investigating an issue affecting the campus telephone system, at locations all across campus. Please monitor this page for updates on the situation. We apologize for the inconvenience.
Posted Aug 12, 2019 - 14:12 PDT
This incident affected: Communication and Collaboration.