Talkdesk issues
Incident Report for ITS Network & Systems
Resolved
ITS has confirmed that the issues affecting Talkdesk have been resolved. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Apr 22, 2024 - 12:04 PDT
Investigating
The Service Desk's call software (as well as BFS, SFS, EdTech) is not functioning this morning and we are unable to take calls
https://status.talkdesk.com/
If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Apr 22, 2024 - 08:30 PDT
This incident affected: Phones and Voicemail.