Student Activity Hub (SAH) Empty or Incomplete

Incident Report for ITS Network & Systems

Resolved

ITS has confirmed that the issues affecting Student Activity Hub (SAH) have been resolved. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted May 29, 2026 - 06:57 PDT

Update

SAH Core and Application data has been loaded, reports using that data can be used. SAH Retention data is still loading
Posted May 28, 2026 - 15:51 PDT

Identified

Identified the root cause but will take sometime to fix.
Posted May 28, 2026 - 07:13 PDT

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 06:43 PDT

Investigating

SAH views are not populating thus empty. The issue is being investigated for root cause. Thank you for your understanding.
Posted May 28, 2026 - 06:39 PDT
This incident affected: Academic Services and Business Services.