Outlook
Incident Report for ITS Network & Systems
Resolved
All problems with the listed service have been resolved.

*Outlook

If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.

Thanks again for your patience during the service outage.
Posted Apr 06, 2021 - 12:22 PDT
Investigating
Our engineers are currently investigating possible issues with the following service:

*Outlook

Outlook for Windows customers may receive a pop-up message when sending to some UCSD recipient that states "We won't be able to deliver this message." We are currently investigating the situation with MS engineers to determine the source of the problem. Customers can use OWA if they are encountering this problems. We will update within the next hour.

Updates and additional details will be shared here once they become available.

If you do notice any additional outages or impacts, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.

Thank you for your patience.
Posted Apr 02, 2021 - 10:51 PDT
This incident affected: Email.