Activity Hubs Not Refreshing

Incident Report for ITS Network & Systems

Resolved

ITS has confirmed that the issues affecting Activity Hubs have been resolved. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 22, 2026 - 14:50 PDT

Investigating

Activity hubs have not been refreshed this morning. The hubs are available but do not contain updates from yesterday.
Posted Jul 22, 2026 - 07:06 PDT
This incident affected: Academic Services.