It looks like the e-transact application where students add money to their triton cash accounts is not working properly,

Incident Report for ITS Network & Systems

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 13:01 PDT

Monitoring

ITS has implemented a fix for the issues with Triton Cash loading funds. We are currently monitoring the situation to ensure our services have been restored. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jul 11, 2026 - 15:20 PDT

Update

We are continuing to investigate this issue.
Posted Jul 11, 2026 - 14:34 PDT

Investigating

ITS is investigating issues with the e-transact application where students add funds to Triton Cash accounts is not working properly.
Posted Jul 11, 2026 - 14:33 PDT
This incident affected: Business Services.