Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 05, 2026 - 17:30 PST
Scheduled
Maintenance will be performed on the Staff Portal and Advising Systems applications starting at 5:30 pm. Apps including the Virtual Advising System (VAC) will be unavailable at the time.
Posted Feb 05, 2026 - 14:00 PST
This scheduled maintenance affected: Academic Services.