Eforms Email Notification Issue

Incident Report for ITS Network & Systems

Resolved

ITS has confirmed that the issues affecting Eforms have been resolved. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jun 27, 2025 - 07:44 PDT

Investigating

ITS is aware of an email notification issue relating to eforms.ucsd.edu and is investigating. Updates and additional details will be shared here as they become available. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Jun 18, 2025 - 14:30 PDT
This incident affected: Email.