Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 17:30 PDT
Scheduled
Due to scheduled maintenance we need to temporarily bring down some GEPA systems which will include the following:
Student DB Application All Academic Affairs Documents in the Student DB Application All Academic Reports in the Student DB Application Spring Evaluations Committee DB Financial Support Request Tool (FSRT)
Posted Mar 12, 2026 - 11:48 PDT
This scheduled maintenance affected: Academic Services and Business Services.