Degree Planner Application
Incident Report for ITS Network & Systems
Resolved
All problems with the listed service have been resolved.

Degree Planner

If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.

Thanks again for your patience during the service outage.
Posted Jun 24, 2021 - 16:05 PDT
Identified
The Degree Planner Application is experiencing intermittent issues upon submission and approval. As a work around, students please download a PDF copy of your plan and email it to your adviser for review if you experience an issue.
Please contact ITS Service Desk at (858)246-HELP(4357) or servicedesk@ucsd.edu if you have any questions or concerns.
Posted Jun 23, 2021 - 12:46 PDT
This incident affected: Academic Services.