Power Outage on Campus

Incident Report for ITS Network & Systems

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 16:27 PST

Monitoring

ITS has been notified that the power outage issue has been resolved. We are currently monitoring the situation to ensure our services have been restored. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Feb 11, 2026 - 15:33 PST

Update

We are continuing to investigate this issue.
Posted Feb 11, 2026 - 10:23 PST

Update

List of locations currently affected:

Muir ResLife
Muir Tuolumne
Muir Tamarack
Muir Tioga
Muir AP&M
Student Center
SSRB
HSS
Cognitive Science
UNEX Buildings
Center Hall
Solis Hall
Tata Hall
Rec Gym
Faculty Club
Media Center
Peterson Hall
Mandeville Hall
RWNLLN
NTPLLN
Muir and North Torrey Pines Living and Learning Neighborhood
Posted Feb 11, 2026 - 10:17 PST

Investigating

ITS is aware of a power outage on campus affecting various buildings. ITS will update this page with buildings affected soon.

Thank you for your patience as our team works to restore functionality for these services. Updates and additional details will be shared here as they become available.

If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Feb 11, 2026 - 10:16 PST
This incident affected: Business Services, Network, and Communication and Collaboration.