TritonLink and Blink Applications
Incident Report for ITS Network & Systems
Resolved
All problems with MyTritonLink and Blink have been resolved.

If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.
Posted Jan 07, 2021 - 14:20 PST
Investigating
There is an intermittent problem with MyTritonlink and Blink applications. We are researching the problem.
Posted Jan 07, 2021 - 13:43 PST
This incident affected: Academic Services.