Student Applications: TritonLink and WebReg
Incident Report for ITS Network & Systems
Resolved
The issue with Student Applications: Tritonlink and WebReg have been resolved. If you do notice any additional outages or impacts, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357. Thank you for your patience.
Posted Feb 13, 2019 - 20:38 PST
Investigating
We are currently investigating an issue affecting student applications including TritonLink and WebReg. Access to these sites may be slow or unavailable during this time; please monitor this page for updates on the situation. We apologize for the inconvenience.
Posted Feb 13, 2019 - 18:25 PST
This incident affected: Academic Services.