Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2025 - 09:15 PDT
Scheduled
ITS will need to perform some emergency maintenance on the database server that supports most of the Graduate Division applications including:
Finacial Support Request Tool (FSRT) GEPA Student Evaluation Graduate Division Student Committee Graduate Division Academic Affairs Documents All the academic reports on Student DB
The emergency maintenance outage will be about 90mins.
Posted May 28, 2025 - 09:13 PDT
This scheduled maintenance affected: Academic Services.