Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2026 - 20:00 PDT
Scheduled
The UC Learning Center will be offline from 8 PM on Friday, March 13 until approximately 12 AM on Saturday, March 14 for a platform upgrade. Would you please add that to status.ucsd.edu? Employees can visit https://blink.ucsd.edu/HR/training/uclc/upgrade.html for more information.
Posted Mar 11, 2026 - 15:46 PDT
This scheduled maintenance affects: Academic Services and Business Services.