LastPass
Incident Report for ITS Network & Systems
Resolved
The intermittent connectivity issues with LastPass have been resolved. If you continue to experience problems with LastPass, please log out of your account and log back in using your master password.

Thanks again for your patience during the service outage.
Posted Nov 20, 2018 - 13:36 PST
Monitoring
LastPass engineers have applied a fix for the intermittent connectivity issues affecting LastPass password manager. They are continuing to monitor the situation to verify that there are no remaining issues.

Thank you for your patience.
Posted Nov 20, 2018 - 12:39 PST
Update
LastPass engineers are working diligently to resolve this outage impacting some LastPass customers.

Updates and additional details will be shared here and on LastPass's status page, https://status.lastpass.com/ once they become available. Thank you for your patience.
Posted Nov 20, 2018 - 11:34 PST
Identified
LastPass engineers are continuing to troubleshoot the intermittent connectivity issues with the LastPass password manager. Offline mode should still be available at this time.

Updates and additional details will be shared here and on LastPass's status page, https://status.lastpass.com/ once they become available. Thank you for your patience.
Posted Nov 20, 2018 - 09:15 PST
Investigating
LastPass engineers are currently investigating intermittent connectivity issues with the LastPass password manager. LastPass may be slow or unavailable in Online mode at this time. In the meantime, you can use LastPass in Offline mode to retrieve your accounts and passwords.

Updates and additional details will be shared here once they become available. Thank you for your patience.
Posted Nov 20, 2018 - 08:25 PST