Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 21, 2023 - 00:00 PDT
Scheduled
On Thursday, September 21, Phase 2 of Transact Payments implementation for Extended Studies students will be going live. This includes eMarket Checkout, ePayment, Payment Plan and Cashiering modules. Email communication will be sent to Extended Studies students several days prior to September 21.
NOTE: This is different from main campus' implementation of Transact Payments (Triton Pay 2.0). Extended Studies has a separate implementation of Transact Payments.
Posted Sep 13, 2023 - 11:39 PDT
This scheduled maintenance affected: Business Services.