Outage for Campus Staff Performance Appraisal (SPA)
Incident Report for ITS Network & Systems
Resolved
All problems with the Campus Staff Performance Appraisal (spa.ucsd.edu) has been resolved.

If you continue to experience problems or have any questions, please contact the ITS Service Desk at servicedesk@ucsd.edu or 858-246-4357.

Thanks again for your patience during the service outage.
Posted Oct 26, 2020 - 14:47 PDT
Update
We are continuing to investigate this issue.
Posted Oct 23, 2020 - 11:54 PDT
Investigating
The Campus Staff Performance Appraisal (spa.ucsd.edu) is currently offline for emergency maintenance. It will likely be offline through early next week. Questions regarding status can be directed to perf-appraisal@ucsd.edu [mailto:perf-appraisal@ucsd.edu].
Posted Oct 23, 2020 - 11:50 PDT
This incident affected: Business Services.