ITS has confirmed that the issues affecting have been resolved. MyTritonLink and WebReg. Thank you for your patience as we worked to restore service. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Nov 13, 2024 - 13:31 PST
Monitoring
ITS has implemented a fix for the issues with the MyTritonLink & WebReg. We are currently monitoring the situation to ensure our services have been restored. If you notice any additional issues or impact, please contact the ITS Service desk at https://support.ucsd.edu, support@ucsd.edu or at (858) 246-4357.
Posted Nov 13, 2024 - 11:43 PST
Investigating
ITS is investigating possible issues with MyTritonLink and WebReg. These services may be slow or unavailable at this time.
Thank you for your patience as our team works to restore functionality for these services. Updates and additional details will be shared here as they become available.