DocuSign
Incident Report for ITS Network & Systems
Resolved
This incident has been resolved.
Posted May 25, 2022 - 19:05 PDT
Update
We are continuing to monitor for any further issues.
Posted May 24, 2022 - 17:06 PDT
Monitoring
DocuSign has implemented a fix for the issues with DocuSign. We are currently monitoring the situation to ensure our services have been restored. Additional updates and details will be shared here as they become available.

If you are still experiencing issues with Docusign, please contact the ITS Service Desk at servicedesk@ucsd.edu or at (858) 246-4357.
Posted May 24, 2022 - 17:05 PDT
Identified
Docusign has identified the cause of issues with Significant progress has been made in developing a plan to bring services back online. Services are being brought back incrementally. These services may be slow or unavailable at this time, and users may experience difficulty.

Thank you for your continued patience as our team works to restore these services as quickly as possible. Additional updates and details will be shared here as they become available.

If you notice any additional issues or impacts, please contact the ITS Service Desk at servicedesk@ucsd.edu or at (858) 246-4357.
Posted May 24, 2022 - 16:00 PDT
Investigating
DocuSign is experiencing a disruption that is affecting its North American Servers (Na1-Na4). During this time, users may experience issues navigating the platform as well as with sending/signing.

Please contact ITS Service Desk at (858)246-HELP(4357) or servicedesk@ucsd.edu if you have any questions or concerns.
Posted May 24, 2022 - 13:52 PDT
This incident affected: Business Services.