Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 04, 2026 - 09:30 PDT
Scheduled
On Monday, May 4 from 9:30 - 11:30 a.m. PT, the UC San Diego recreation site is being updated for accessibility compliance. During this timeframe the website will be temporarily unavailable.
Posted Apr 30, 2026 - 11:19 PDT
This scheduled maintenance affected: Business Services.