CSC BLDG. B PD NGN D12 Switch Upgrade

Scheduled for May 10, 21:00 PDT  -  May 11, 03:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 30, 2026 - 14:43 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 30, 2026 - 14:42 PDT

Scheduled

Starting Sunday May 10th at 9:00 p.m. and concluding on Monday May 11th at 3:00 a.m. PT, ITS will be replacing existing switches at CSC BLDG B with new switches per NGN D12 upgrade.
Posted May 07, 2026 - 12:18 PDT
This scheduled maintenance affects: Network.